Delays in Scheduled Recognitions
Incident Report for Reward Gateway
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 21:35 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 29, 2024 - 19:26 UTC
Identified
A few customers are encountering delays in receiving their scheduled recognitions. These recognitions are being dispatched in batches, and they should receive them shortly.
Posted Feb 29, 2024 - 18:41 UTC
This incident affected: Reward & Recognition.