Unable to place order through Amazon Canada
Incident Report for Reward Gateway
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 09:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Mar 12, 2024 - 16:50 UTC
Identified
The issue has been identified and we are in the process of restoring the service.
Posted Mar 12, 2024 - 12:21 UTC
This incident affected: Reward Marketplace (Amazon Marketplace - CA).