Possible site issues
Incident Report for Reward Gateway
Resolved
On 1 Nov 2023 07:23 GMT during a scheduled maintenance release one of the database changes was run without the tooling available to prevent locks on tables. This increased response times as the application waited for the database tables to unlock when the change completed.


At 07:28 GMT Automated alerts were triggered about high response times and an Engineer started investigating.


At 07:35 GMT It was found that some database changes did not get detected by tooling to prevent this behaviour, because they used a different syntax. Further maintenance was paused to make sure no other changes with similar syntax ran without review first.


At 07:37 GMT The database change had finished applying and the database started catching up, response time was improving.


At 07:44 GMT Database caught up, the response time has returned to normal
Posted Nov 02, 2023 - 06:34 UTC
Identified
Our automated systems have detected that it is not possible to log in to the site from some locations. An Engineer has been notified and is investigating. More details will be posted here when they are available.
Posted Nov 01, 2023 - 07:44 UTC
This incident affected: SmartSpending™ (UK, Australia).